Daily archives: Tuesday, May 11, 2010
Some quick notes and news about the book!
Anything you create in the global namespace has the potential to conflict with a theme, another plugin (including one you wrote), and WordPress core itself. Thus, prefix everything with a unique-enough character set. For example, all functions I write always start with “nacin_”, and I make sure that my functions are unique across all of my plugins.
In this recent post, I used some fairly generic function names like
custom_css_hooks. Andrew is saying that names like that are a little too generic and that it's possible another plugin could use that same name which would be rather disastrous. Since it's totally internal anyway, I should have called it
digwp_custom_css_hooks, which would be far less likely to meet a conflict.
Yes, it runs WordPress on Windows and SQL Server.
Editor's note: 404 link removed.